FAQ:旧バージョン(2021.1)のIntel oneAPI 2021を利用するには

現在の運用バージョンは 2021.3ですが、旧バージョン(2021.1)のIntel oneAPIを利用する場合は、2種類の環境変数設定ファイルの読み込みが必要です。

source /mnt/stfs/comp/oneapi2021.1/setvars.sh intel64
source /mnt/stfs/comp/oneapi2021.1/mpi/latest/env/vars.sh intel64

コンパイラを利用する前に、上記コマンドを実行して下さい。

プログラム実行時にも環境変数ファイルの読み込みが必要となります。#!/bin/shから始まるジョブスクリプトファイル内に記述して下さい。

環境変数設定ファイルはbash形式のみの提供です。tcshでは利用出来ません。

タイトルとURLをコピーしました